LỚP DD07KSTN

LỚP DD07KSTN


 
Trang ChínhCalendarTrợ giúpTìm kiếmThành viênNhómĐăng kýĐăng Nhập
June 2018
MonTueWedThuFriSatSun
    123
45678910
11121314151617
18192021222324
252627282930 
CalendarCalendar
Latest topics
Keywords

Share | 
 

 Hỏi về layout??

Go down 
Tác giảThông điệp
motngaymoi1340
thử việc
thử việc


Tổng số bài gửi : 1
Join date : 24/05/2010

Bài gửiTiêu đề: Hỏi về layout??   Mon May 24, 2010 8:21 pm

AutoECO báo lỗi
FILE-A: C: \ Documents and Settings \ Administrator \ DESKTOP \ HUYNH \ H1 \ CAPTURE_FAN_LED \ CE_LED.MAX
FILE-B: C: \ Documents and Settings \ Administrator \ DESKTOP \ HUYNH \ H1 \ CAPTURE_FAN_LED \ CE_LED.MNL
LỖI: Điện gói CAPACITOR_NON-POL cho comp C5V_1 có ít nhất một pin (2)
mà không có pin tương ứng trên chân TU 1000-1035 PN.
Bạn có thể tạo hoặc sửa đổi một dấu chân, chọn một tên khác,
hoặc nhấn Cancel ở hộp thoại chính để bỏ qua thành phần này.
LỖI: Không có dấu chân được tìm thấy cho comp C5V_1
Không thể để hoàn thành ECO do lỗi
1 lỗi được tìm thấy
Post bài lên hộ tôi:
“AutoECO Error Report
FILE-A: C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\HUYNH\H1\CAPTURE_FAN_LED\CE_LED.MAX
FILE-B: C:\DOCUMENTS AND SETTINGS\ADMINISTRATOR\DESKTOP\HUYNH\H1\CAPTURE_FAN_LED\CE_LED.MNL
ERROR: Electrical package CAPACITOR_NON-POL for comp C5V_1 has at least one pin (2)
which has no corresponding pin on footprint TU 1000/35 PN.
You may create or modify a footprint, choose another,
or press Cancel at the main dialog to skip this component.
ERROR: No footprint found for comp C5V_1
Unable to complete ECO due to errors
1 error found”
Mình tạo file layout từ capture trong thư viện layout mìnhcó add thêm thư viện phuong.llb và add footprint vào các linh kiện và tạo file .mnl thì nó báo lỗi chỗ tụ C5V_1 mặc dù mình thay các loại footprint khác ai biết lỗi chỉ dùm nhé!!
Sleep Sleep Sleep
Về Đầu Trang Go down
Xem lý lịch thành viên
Lee
phó tổng giám đốc
phó tổng giám đốc
avatar

Tổng số bài gửi : 106
Join date : 29/12/2009
Age : 28
Đến từ : Tây Ninh

Bài gửiTiêu đề: Re: Hỏi về layout??   Mon May 24, 2010 9:22 pm

Àh, cái này có thể do lỗi trong capture, linh kiện bạn vẽ trong capture ko tương thích với number pin trong footprint. Chẳng hạn bên capture, 2 chân của tụ được đánh dấu là 1 2, còn bên layout lại là N P. Sữa chữa bằng cách vào capture, chọn cái tụ đó, chuột phải, edit part, click chuột trái vào các chân linh kiện, đổi tên nó lại cho tương ứng với footprint. Bạn thử xem sao. Chúc may mắn!
Về Đầu Trang Go down
Xem lý lịch thành viên
danhtuot
thử việc
thử việc


Tổng số bài gửi : 3
Join date : 22/05/2010

Bài gửiTiêu đề: mình không dán tên footprint cho linh kiện được.   Mon May 24, 2010 10:29 pm

Sau khi chọn dạng chân linh kiện, mình copy tên dạng chân đó và click chuột trái 2 lần để dán vào ô PCB FOOTPRINT nhưng không được, không hiểu tại sao? giúp mình với.
Về Đầu Trang Go down
Xem lý lịch thành viên
lethanhtoan
phó tổng giám đốc
phó tổng giám đốc


Tổng số bài gửi : 101
Join date : 31/12/2009
Age : 29

Bài gửiTiêu đề: Re: Hỏi về layout??   Mon May 24, 2010 10:36 pm

Bạn thử dùng Ctrl+C rồi Ctrl+V xem duoc ko ?
Về Đầu Trang Go down
Xem lý lịch thành viên
vanquy311
phó tổng giám đốc
phó tổng giám đốc
avatar

Tổng số bài gửi : 146
Join date : 28/12/2009
Age : 29
Đến từ : The Hell

Bài gửiTiêu đề: Re: Hỏi về layout??   Mon May 24, 2010 10:38 pm

Bổ sung cho bạn nữa là:
Trường hợp của bạn gần giống trường hợp của mình khi vô phòng thực tập điện B (vào đúng máy số 13) nên xui xẻo,tình hình là khi mình đã copy các footprint từ các thư viện ngoài vào các linh kiện của mình trong capture,có kiểm tra pin và number của từng footprint,nhưng khi tao xong file *.mnl và qua bên layout để tạo file vẽ thì nó load file *mnl báo lỗi cũng như bạn
"which has no corresponding pin on footprint TU 1000/35 PN.
You may create or modify a footprint, choose another,
or press Cancel at the main dialog to skip this component.
ERROR: No footprint found for comp C5V_1"

tình hình này làm minh xoay sở cả 2 tiếng trong phỏng thí nghiệm mà chẳng biết sửa thế nào,cách sửa chung cho loại này theo kinh nghiệm của mình đối với mấy cái máy gà gà trong phòng thí nghiệm (load các thư viện trong capture mà kích từng cái một,bấm all không được,chưa kể dùng loại orcad 6.0)
Bạn nên kích vào linh kiện,xóa hết tên chân các footprint,nhớ là xóa hết tất cả linh kiện trong sơ đồ orcad,sau khi đã xóa xong bạn tạo file netlist(vẫn tạo được nếu bạn vẽ mạch đúng),sau qua bên layout mở file *.mnl rồi layout báo cấp các footprint cho nó thì bạn bắt đầu chọn từ library các footprint,nếu footprint nào không hợp thì nó sẽ báo lỗi tại đó rồi bạn chọn cái khác cho phù hợp.Sau rồi nó sẽ tạo file layout với đầy đủ các linh kiện cho bạn!

Về Đầu Trang Go down
Xem lý lịch thành viên
Nhok_kid
phó giám đốc
phó giám đốc
avatar

Tổng số bài gửi : 66
Join date : 29/12/2009
Age : 28
Đến từ : Hà Tĩnh

Bài gửiTiêu đề: Re: Hỏi về layout??   Tue May 25, 2010 12:28 am

Hôm trc vẽ capture xong tạo netlist rồi vô layout nhưng ko hiểu sao mất hẳn 1 linh kiện???
ko báo lỗi khi check và tạo netlist bên capture.
có ai biết tại sao ko?
Về Đầu Trang Go down
Xem lý lịch thành viên
muilevan
trưởng phòng
trưởng phòng


Tổng số bài gửi : 40
Join date : 29/12/2009
Age : 29
Đến từ : Quảng Ngãi

Bài gửiTiêu đề: Re: Hỏi về layout??   Tue May 25, 2010 1:34 am

Mình cũng đã từng bị như thế này!đem qua máy người khác thì được nhưng còn máy mình thì không báo lỗi gì nhưng và cũng chẳng thấy gì bên layout cả!chắc cái này phải hỏi bác release design system quá! hehe !nhưng mà do xài chui nên không dám hỏi!có thể do xài chui nên có những lỗi không biết trước được!cũng có khi do thư viện footprint của nó,nếu như bạn chưa add footprint riêng của mình bên capture nó sẽ lấy footprint default (mà ai biết nó ở đâu và như thế nào).cũng có khi do máy phòng thực tập xin quá cũng nên...Nói túm lại là không biết!hehe
Nhưng để tranh trường hợp này thì bạn có 3 cách:
1. làm như Quý đó (tốn nhiều thời gian nếu như số linh kiện của bạn nhiều),báo lỗi ngay tại linh kiện đó luôn..nếu footprint không đúng
2. Cũng với ý tưởng như Quý nhưng bạn k cần làm gì cả bên capture, cứ tạo nestlist bình thường!không báo lỗi gì là okay!bên LAYOUT bạn remove tất cả các thư viện của nó đi,chỉ để lại thư viện riêng của ban thôi(ví dụ chỉ để thư viện của chị phương thôi chẳng hạn)!khi đó khi mở file .MNL nó sẽ không tìm thấy thư viện chân default của nó và chắc chắn nó sẽ hỏi bạn!bạn cứ link đến đúng footprint trong thư viện riêng của mình là được!
3. ( hơi công phu 1 tí);bạn tạo cho mình 1 thư viện capture có add sẵn footprint (thực ra chỉ lấy thư viện có sắn của capture rồi add footprint của mình vô sửa lại thành của minh mà thôi).nhiều người ít quan tâm đến thư viện capture mà chỉ chú ý đến thư viện Layout nhưng minh nghĩ thư viện Capture cũng quan trong kém gì layout!
bên capture bạn chỉ dùng thư viện của minh tạo(nhớ là đã add footprint rồi)!khi đó bạn không cần quan tâm đến footprint nữa!đều này rất có lợi nếu như mạch của bạn có số linh kiện lớn và lặp đi lặp lại những linh kiện giống nhau(việc add footprint cho từng linh kiện sẽ tốn nhiều thời gian trong khi nhiều linh kiện cùng 1 footprint)

nếu bạn dùng 1 trong 3 cách đó thì mình chắc chắn sẽ k bị lỗi như trên cho dù linh kiện đó bạn quên k nối wire bên capture đi nữa(nếu vẫn còn lỗi thì chỉ con nước đi hỏi bác release thôi)
đó là gì mình biết hi vọng sẽ có ích cho bạn!
mong mọi người cùng nhau chia sẻ!
Về Đầu Trang Go down
Xem lý lịch thành viên
danhtuot
thử việc
thử việc


Tổng số bài gửi : 3
Join date : 22/05/2010

Bài gửiTiêu đề: khoảng cách linh kiện khi vẽ layout?   Tue May 25, 2010 4:45 pm

Khi sắp xếp linh kiện trong layout, ta nên xếp khoảng cách giữa 2 linh kiện là bao nhiêu?
Về Đầu Trang Go down
Xem lý lịch thành viên
Lee
phó tổng giám đốc
phó tổng giám đốc
avatar

Tổng số bài gửi : 106
Join date : 29/12/2009
Age : 28
Đến từ : Tây Ninh

Bài gửiTiêu đề: Re: Hỏi về layout??   Tue May 25, 2010 5:04 pm

Bạn sắp sao cho các đường bao linh kiện(màu xanh lá cây) không trùng lên nhau là được, đó là khoảng cách tối thiểu. Nếu để gần quá thì sẽ autoroute khó, rất có thể sử dụng đến jump(không tốt ). Để xa quá thì đường dây đi dễ nhưng lại lãng phí board và mặt top trông rất xấu. Bạn cần điều chỉnh khoảng cách hợp lí cho tùy board mạchl
Về Đầu Trang Go down
Xem lý lịch thành viên
blue
giám đốc điều hành
giám đốc điều hành
avatar

Tổng số bài gửi : 96
Join date : 28/12/2009
Age : 28
Đến từ : ninh thuận

Bài gửiTiêu đề: Re: Hỏi về layout??   Tue May 25, 2010 5:17 pm

cái này không giới han đâu bạn.bạn làm càng tốn ít diện tích càng tốt.linh kiện sát nhau cũng không sao (chỉ khổ khi bạn hàn mạch thôi).trừ một vài linh kiện công suất cần có tản nhiệt thì cần tính đến diện tích của tản nhiệt nữa,và đừng để nó quá sát mấy con khác không, thì mấy con đó lãnh đủ
Về Đầu Trang Go down
Xem lý lịch thành viên
huutan831073
thử việc
thử việc


Tổng số bài gửi : 7
Join date : 29/01/2010

Bài gửiTiêu đề: vần đề qua layout bị mất linh kiện   Sat May 29, 2010 8:47 pm

mình đã tìm hiểu vấn đề đó rồi, nhưng mà hiếm khi xảy ra lắm. có thể khi ta làm không để ý, chứ khó mất lắm, hoặc 1 trường hợp có thể xảy ra là layout bị lổi
Về Đầu Trang Go down
Xem lý lịch thành viên
Sponsored content




Bài gửiTiêu đề: Re: Hỏi về layout??   

Về Đầu Trang Go down
 
Hỏi về layout??
Về Đầu Trang 
Trang 1 trong tổng số 1 trang

Permissions in this forum:Bạn không có quyền trả lời bài viết
LỚP DD07KSTN :: Câu lạc bộ nghiên cứu khoa học :: Cuộc thi FAN LED-
Chuyển đến